Why is my dot Board not connecting with my dot Remote?

You’ve got your dot Board and dot Remote charged up, and everything should be working fine – but they don’t seem to be connecting to each other. What now?

The first thing is to check that both your dot Board and dot Remote are both on and running. For the dot Remote, that means pressing ‘down’ on the directional pad. For your dot Board, that means rolling the wheels with motors in them over either on the ground or by hand. This should activate the ‘search’ feature in your remote and board – and connect them when they ‘find’ each other.

If this hasn’t worked, you can try re-pairing the dot Remote to your dot Board. On your dot Remote:

  1. Scroll down to ‘Options’ and press right to select.
  2. Scroll down to ‘Pair Remote’ and press right to select.
  3. Press up when prompted. This tells the dot Remote to search.
  4. Spin the rear motor wheel over in three short bursts, stopping the motor between each spin.

Turning the motors over on your dot Board by hand mimics the ‘Push to Start’ process. Speed is important, and you may need to try this method a couple times. For a video demonstration of this method, check out this video.

If you’ve tried these steps and are still experiencing issues getting your dot Board connected with your dot Remote, don’t hesitate to reach out to the team via our Contact Form.